1 About This Document

1.1 Scope of the Document
This document outlines the ICONICS Recipe Management System by providing examples that illustrate the capabilities of this tool in ICONICS GENESIS32 which can be used to manage and control real-time processes. The intended audience for this document includes engineers, sales, support, and marketing personnel to gain an understanding of this process management tool.

1.2 Copyright
This document is © Copyright 2007, ICONICS Inc., Foxborough, Massachusetts.

TRADEMARKS: Recipe Management System, Recipe ActiveX, TreeControl ActiveX are trademarks of ICONICS, Inc.

1.3 Revision History

1.4 Definitions
The following acronyms are used in this document, and are presented below for reference purposes:

UDM – Unified Data Manager
OPC – OLE for Process Control
RMS – Recipe Management System
PLC – Programmable Logic Controller
2 Introduction

2.1 Purpose of Recipe Management
ICONICS Recipe Management System partners with the ICONICS GraphWorX32 software to accommodate process sequence shifting via a customized set of recipes. A recipe contains an array of ingredient parameters that are adjustable and linked to their specified OPC tags. The predefined recipe is downloaded from the UDM database to the PLCs of a system. The ingredients can also incorporate individual properties such as Flavor, Size, Quantity, and Strength.
3 Recipe Management System Basics

3.1 Unified Data Manager

The Unified Data Manager is a database that stores sets of data for ICONICS software. First, configure the Unified Data Manager, access it in Windows via Start → All Programs → ICONICS Tools → Unified Data Manager (UDM). Once the UDM has loaded, use the Tree Control in the left part of the window to expand the listings. When expanded, you will see several directories including Expressions, Groups, Recipes, Event Triggers, and Alarm Filters. Double click “Recipes” and obtain the configuration for the Pills recipe. This is the Recipe Server where each recipe can be designed, configured, stored, and it is the centralized source for data access in the Recipe Management System.

To edit the parameters of each recipe, choose an OPC tag by clicking on the appropriate Parameter name within the Recipe Parameters tab. Once highlighted, click on the Parameter Details tab to adjust the recipe characteristics. These characteristics can be adjusted to match a physical system’s constraints.

For additional information regarding recipe configuration properties, please refer to the Unified Data Manager help documentation.

In the Parameter Details, you must give each recipe parameter an appropriate name. For each parameter you can define a range of values (minimum and maximum) and specify the unit of measurement (e.g. degrees, minutes, etc.).

Once you have created a recipe configuration by customizing several Recipe Parameters to suit your system’s functionality, you can begin adding recipe items to the configuration.

In the Recipe Item Values tab for each recipe item, you can specify the value (e.g. quantity, strength, flavor) for each of the parameters (ingredients) included in the recipe by clicking the Edit Value button.

3.2 Recipe and Tree Control ActiveX Configuration

Start by creating a new GraphWorX32 display and insert the Tree Explorer ActiveX and the Recipe ActiveX into the display by clicking the appropriate buttons on the ActiveX toolbar. You may also choose Edit → Insert New Object… from the top menu bar, and select the Tree Explorer ActiveX. Repeat this step to insert the Recipe ActiveX. This creates a recipe control panel for easy to manage recipe-based process control.
Double-click on the newly established Tree Explorer ActiveX and go to the **Tab Configuration** tab in the **Properties** dialog box. Click the **Insert Tab** button to create a tab for browsing recipe items. In the example covered in the next chapter, the tab is named "Recipe". Under **Tab Type**, select **Recipe Explorer** from the drop-down list. Under **Recipe View ID**, enter an ID for the recipe that will be used to connect the Tree Explorer ActiveX to the Recipe ActiveX.

Double-click on the Recipe ActiveX and go to the **General** tab in the window that has opened. The **Recipe View ID Binding** field lists all recipe view IDs that you configured in the Tree Explorer ActiveX. Choose the recipe view ID that you want to use, (matching with the Recipe View ID in the **Tree Explorer ActiveX**), from the drop-down list. The "Recipe1" view ID is selected. Be sure to link the **Tree Explorer ActiveX** configuration above to the **Recipe ActiveX** by matching the Recipe View ID in the **Tree Explorer ActiveX** with the **Recipe View ID Binding**. Save these configurations and return to the main screen.

### 3.3 Runtime Configuration

Click the **Runtime** option at the top menu in GraphWorX32 to start runtime mode. The Tree Explorer ActiveX displays the recipes and recipe items from the active recipe configuration that was established in the Unified Data Manager.

When you click on a recipe item in the Tree Explorer ActiveX, the parameters (ingredients) are displayed in the Recipe ActiveX, which consists of a data table with rows and columns. Each row lists a parameter, and for each parameter there are multiple data columns for units, minimum value, maximum value, value, associated OPC tag, etc.

In runtime mode, the Recipe ActiveX allows you to change the values of recipe parameters (ingredients) in real time. To change a value, you can simply click inside the data table in the **Value** column and type in the new value, as shown in Figure 9.

When you change the values of recipe parameters in the Recipe ActiveX, you need to update the values to the Recipe Server, which then applies the changes to the active recipe configuration. Each recipe parameter is associated with an OPC tag, so you also need to download the updated values the OPC server.

You can do this by using the **Recipe Pick Action** in GraphWorX32, which allows you to save new values to the recipe configuration and download recipe values to the OPC server, which then relays the new values to the PLC device in the end-user application. To accomplish this, you can setup recipe pick actions that perform these specified actions. To set up the recipe pick action, create a push button in the GraphWorX32 display by selecting **Dynamics → Intrinsics → Push Button** from the top menu. Inside the **Pick** tab of the **Property Inspector** dialog box that opens, select **Recipe Action** from the **Action** drop-down list. Under **Recipe Identification**, select the name of the recipe view ID (in this example, the view ID is named "Recipe1").
Select one of the following button types for the recipe pick action. In the example developed in the next chapter, all five button types have been added to the recipe display in configuration mode.

- **Save**: Saves the changes made to the currently selected recipe item in the Tree Explorer ActiveX to the Recipe Server, which then updates the changes in the active recipe configuration.
- **Save As**: Duplicates the currently selected item in the Tree Explorer ActiveX and inserts a copy of the item into the tree control. The copy of the item includes an identical set of recipe item values.
- **Delete**: Deletes the currently selected recipe item from the Tree Explorer ActiveX.
- **Restore**: Resets any changed recipe values in the Recipe ActiveX to the previous values.
- **Download**: Applies all changes (if necessary) and downloads the values of the currently selected recipe item in the Tree Explorer ActiveX from the Recipe Server to the OPC servers. The OPC servers resolve the values of the recipe and then relays the information to the PLC device to implement the changes in the end-user application.

**Once you have started Runtime mode, the buttons created will become active.**

When you change the value of a recipe parameter in the Recipe ActiveX (e.g. the **Quantity** is changed from 400 to 200), you must click the **Save** button to commit the value changes to the Recipe Server.

The Recipe Server then updates the value change in the active recipe configuration. To see the recipe configuration change in the Unified Data Manager, select **Global Refresh** from **View** menu in the Unified Data Manager configurator, and then go to the **Recipe Item Values** tab. There you will see the value for the **Quantity** has changed from 400 to 200.

Each recipe parameter is associated with an OPC tag, so you also need a way to download the updated values to the connected OPC servers. After you save the recipe value changes, click the **Download** button in the GraphWorX32 to download the values from the Recipe Server to the OPC servers.
4 Example: Recipe Management Configuration

4.1 Pharmaceutical Recipe Management

This example runs through a specific step-by-step process to achieve a Pharmaceutical Pills Recipe Configuration.

First, configure your recipe by accessing the Unified Data Manager. This is located under Start → All Programs → Iconics Tools → Unified Data Manager (UDM). Once the UDM has loaded, use the Tree Control in the left part of the window to expand the listing titled Recipes. When expanded, you will see a recipe folder named “Pills”. Within that recipe folder you will see a recipe “Pills” to obtain parameters for the Pills recipe simply highlight the ‘Pills’ recipe and you will see the parameters. In the Acmeesetual example shown in Figure 1, the Pills recipe includes seven parameters, and each parameter has a unique Index number, as seen in the Recipe Parameters tab.

Each of these recipe parameters is associated with an OPC tag, which allows the connected OPC server to communicate recipe values between the Recipe Server and the PLC device in an end-user application. To edit the parameters of each recipe, choose an OPC tag by clicking on the appropriate Parameter name within the Recipe Parameters tab. Once highlighted, click on the Parameter Details tab to adjust the recipe characteristics. These characteristics can be adjusted to match a physical system’s constraints.

For additional information regarding recipe configuration properties, please refer to the Unified Data Manager help documentation.

Figure 1: Recipe Configuration in the Unified Data Manager- Recipe Parameters
In the **Parameter Details** tab shown in Figure 2, you must give each recipe parameter an appropriate name. The seven parameters in the example recipe configuration shown in the figure below have the following names: **Temperature, IngredientA, IngredientB, IngredientC, TankD, Limit, ValvePos**. For each parameter you can define a range of values (minimum and maximum) and specify the unit of measurement (e.g. degrees, minutes, etc.).

![Recipe Configuration in the Unified Data Manager - Parameter Details](image)

**Figure 2: Recipe Configuration in the Unified Data Manager - Parameter Details**

Once you have created a recipe configuration by customizing several Recipe Parameters to suit your system’s functionality, you can begin adding recipe items to the configuration. In the example shown in Figure 3, the "Pills" recipe includes twelve recipe items: **Regular, Extra Strength, Fast Acting Formula, Candy Coated, Iron Added, OEM-A, OEM-B, OEM-C, OEM-D, OEM-E, OEM-F and Original**.

In the **Recipe Item Values** tab for each recipe item, you can specify the value (e.g. Temperature, ValvePos, Limit) for each of the parameters included in the recipe by clicking the **Edit Value** button, as shown in the figure below. In this example, all recipe items contain the same parameters (**Temperature, IngredientA, IngredientB, IngredientC, TankD, Limit, ValvePos**), but the values for those parameters vary for each recipe item.
Finally to make use of the new recipe functionality that has just been configured you can create a new GraphWorx32 display and insert the Tree Explorer ActiveX and the Recipe ActiveX into the display by clicking the appropriate buttons on the ActiveX toolbar. You may also choose Edit → Insert New Object… from the top menu bar, and select the Tree Explorer ActiveX. Please repeat this step to also insert the Recipe ActiveX. This creates a recipe control panel for the management of recipe-based process control.
Double-click on the newly established Tree Explorer ActiveX and go to the Tab Configuration tab in the Properties dialog box, as shown in Figure 5. Click the Insert Tab button to create a tab for browsing recipe items. In the example shown below, the tab is named "Recipe". Under Tab Type, select Recipe Explorer from the drop-down list. Under Recipe View ID, enter an ID for the recipe that will be used to connect the Tree Explorer ActiveX to the Recipe ActiveX. In Figure 5 below, the Recipe View ID is "Recipe1". Click OK.

![Figure 5: Tree Explorer ActiveX: Tab Configuration Tab](image)

Double-click on the Recipe ActiveX and go to the General tab in the window that has opened, shown in Figure 6. The Recipe View ID Binding field lists all recipe view IDs that you configured in the Tree Explorer ActiveX. Choose the recipe view ID that you want to use, (matching with the Recipe View ID in the Tree Explorer ActiveX), from the drop-down list. In the example shown in Figure 6, the "Recipe1" view ID is selected. This view ID will be used to link the Tree Explorer ActiveX configuration above to the Recipe ActiveX. To complete this step, you will need to match the Recipe View ID in the Tree Explorer ActiveX with the Recipe View ID Binding, will be used to link the Tree Explorer ActiveX configuration above to the Recipe ActiveX. Please save these settings and return to the GraphWorX32 home screen.

![Figure 6: Recipe ActiveX Properties Window](image)
Click the **Runtime** option at the top menu in GraphWorX32 to start runtime mode. As you can see in the figure below, the Tree Explorer ActiveX displays the recipes and recipe items from the active recipe configuration in the Unified Data Manager. In the example shown in Figure 7, the "Pills" recipe is selected, and its twelve recipe items are displayed in the tree control: **Regular, Extra Strength, Fast Acting Formula, Candy Coated, Iron Added, OEM-A, OEM-B, OEM-C, OEM-D, OEM-E, OEM-F** and **Original**.

When you click on a recipe item in the Tree Explorer ActiveX, the parameters are displayed in the Recipe ActiveX, which consists of a data table with rows and columns. Each row lists a parameter, and for each parameter there are multiple data columns for units, minimum value, maximum value, value, associated OPC tag, etc. In the example recipe configuration found in Figure 8, the parameters are **Temperature, IngredientA, IngredientB, IngredientC, TankD, Limit, and ValvePos**.

![Figure 7: Recipe Control Panel - Extra Strength Pills](image)

![Figure 8: Recipe Management Control Panel](image)
In runtime mode, the Recipe ActiveX allows you to change the values of recipe parameters in real time. To change a value, you can simply click inside the data table in the Value column and type in the new value, as shown in Figure 9. When you change the values of recipe parameters in the Recipe ActiveX, you need to update the values to the Recipe Server, which then applies the changes to the active recipe configuration. Recipe Pick Actions can be created and applied to perform these buttons within a GraphWorX32 page. You can also add the buttons seen at the bottom of Figure 9 via the Symbol Library. Please see GraphWorX32 Help for additional information regarding the development of these buttons.

![Figure 9: Control Panel Runtime Value Modification](image)

To set up the recipe pick action, create a push button in the GraphWorX32 display by selecting Dynamics → Intrinsics → Push Button from the top menu. Inside the Pick tab of the Property Inspector dialog box that opens, select Recipe Action from the Action drop-down list, as shown in the figure below. Under Recipe Identification, select the name of the recipe view ID (in this example, the view ID is named "Recipe1"). Each recipe parameter is associated with an OPC tag, so you also need to download the updated values the OPC server. You can do this by using the Recipe Pick Action in GraphWorX32, which allows you to save new values to the recipe configuration and download recipe values to the OPC server, which then relays the new values to the PLC device in the end-user application.
Select one of the following button types for the recipe pick action. In the example shown in the figure below, all five button types have been added to the recipe display in configuration mode.

- **Save**: Saves the changes made to the currently selected recipe item in the Tree Explorer ActiveX to the Recipe Server, which then updates the changes in the active recipe configuration.
- **Save As**: Duplicates the currently selected item in the Tree Explorer ActiveX and inserts a copy of the item into the tree control. The copy of the item includes an identical set of recipe item values.
- **Delete**: Deletes the currently selected recipe item from the Tree Explorer ActiveX.
- **Restore**: Resets any changed recipe values in the Recipe ActiveX to the previous values.
- **Download**: Applies all changes (if necessary) and downloads the values of the currently selected recipe item in the Tree Explorer ActiveX from the Recipe Server to the OPC servers. The OPC servers resolve the values of the recipe and then relays the information to the PLC device to implement the changes in the end-user application.
When you start runtime mode, the push buttons are enabled, as shown in Figure 11.

When you change the value of a recipe parameter in the Recipe ActiveX (e.g. the IngredientA is changed from 444 to 200 in the figure below), you must click the Save button to commit the value changes to the Recipe Server.

The Recipe Server then updates the value change in the active recipe configuration. To see the recipe configuration change in the Unified Data Manager, select Global Refresh from View menu in the Unified Data Manager configurator, and then go to the Recipe Item Values tab, as shown in the figure below. As you can see in the example below, the value for the IngredientA has changed from 444 to 200.
Each recipe parameter is associated with an OPC tag, so you also need a way to download the updated values to the connected OPC servers. After you save the recipe value changes, click the **Download** button in the GraphWorX32 to download the values from the Recipe Server to the OPC servers. The OPC servers resolve the values of the recipe and then relay the information to the PLC device to implement the changes in the end-user product. The recipe that is selected will be the process that is currently running.

*Figure 11: UDM shows the value change from the modification made in runtime mode*
5 Summary

Having completed the walk through of our Pharmaceutical example you have had a good look at the functionality of the new recipe system and each of its components; Including the Tree Control ActiveX, the Recipe Grid, the Recipe Pick Actions, and the UDM recipe configuration tools. These components combined now give you the necessary tools to allow you to create your own recipe management system with the flexibility to modify each element to satisfy your recipe requirements.
Founded in 1986, ICONICS is an award-winning independent software developer offering real-time visualization, HMI/SCADA, energy, fault detection, manufacturing intelligence, MES and a suite of analytics solutions for operational excellence. ICONICS solutions are installed in 70% of the Fortune 500 companies around the world, helping customers to be more profitable, agile and efficient, to improve quality and be more sustainable.

ICONICS is leading the way in cloud-based solutions with its HMI/SCADA, analytics, mobile and data historian to help its customers embrace the Internet of Things (IoT). ICONICS products are used in manufacturing, building automation, oil & gas, renewable energy, utilities, water/wastewater, pharmaceuticals, automotive and many other industries. ICONICS’ advanced visualization, productivity, and sustainability solutions are built on its flagship products: GENESIS64™ HMI/SCADA, Hyper Historian™ plant historian, AnalytiX® solution suite and MobileHMI™ mobile apps. Delivering information anytime, anywhere, ICONICS’ solutions scale from the smallest standalone embedded projects to the largest enterprise applications.

ICONICS promotes an international culture of innovation, creativity and excellence in product design, development, technical support, training, sales and consulting services for end users, systems integrators, OEMs and Channel Partners. ICONICS has over 300,000 applications installed in multiple industries worldwide.

World Headquarters
100 Foxborough Blvd.
Foxborough, MA, USA, 02035
Tel: 508 543 8600
Email: us@iconics.com
Web: www.iconics.com

European Headquarters
Netherlands
Tel: 31 252 228 588
Email: holland@iconics.com

Czech Republic
Tel: 420 377 183 420
Email: czech@iconics.com

France
Tel: 33 4 50 19 11 80
Email: france@iconics.com

China
Tel: 86 10 8494 2570
Email: china@iconics.com

Italy
Tel: 39 010 46 0626
Email: italy@iconics.com

UK
Tel: 44 1384 246 700
Email: uk@iconics.com

India
Tel: 91 22 67291029
Email: india@iconics.com

Germany
Tel: 49 2241 16 508 0
Email: germany@iconics.com

Australia
Tel: 61 2 9605 1333
Email: australia@iconics.com

Middle East
Tel: 966 540 881 264
Email: middleeast@iconics.com

©2015 ICONICS, Inc. All rights reserved. Specifications are subject to change without notice. AnalytiX and its respective modules are registered trademarks of ICONICS, Inc. GENESIS64, GENESIS32, Hyper Historian, BizViz, PortalWorX, MobileHMI and their respective modules, OPC-To-The-Core, and Visualize Your Enterprise are trademarks of ICONICS, Inc. Other product and company names mentioned herein may be trademarks of their respective owners.